aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-04-14 12:49:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-04-14 12:49:30 +0000
commit1ea8e3cacacc3f245fe4086c13d0a1c90f6987da (patch)
tree81647beccb8d9f52f95681f91dbad83ec57a4878 /include
parent834e60c4f16b3131c9dd51a0bc00bd47222f57a6 (diff)
downloadupstream-1ea8e3cacacc3f245fe4086c13d0a1c90f6987da.tar.gz
upstream-1ea8e3cacacc3f245fe4086c13d0a1c90f6987da.tar.bz2
upstream-1ea8e3cacacc3f245fe4086c13d0a1c90f6987da.zip
build: replace the deprecated find argument -perm +0100 with /0100 (#19480)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45434
Diffstat (limited to 'include')
-rw-r--r--include/image.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index 6e0456f42a..31689c7e6b 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -244,8 +244,8 @@ endef
define Image/mkfs/prepare/default
# Use symbolic permissions to avoid clobbering SUID/SGID/sticky bits
- - $(FIND) $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' -not -name 'shadow' -print0 | $(XARGS) -0 chmod u+rw,g+r,o+r
- - $(FIND) $(TARGET_DIR) -type f -perm +0100 -print0 | $(XARGS) -0 chmod u+rwx,g+rx,o+rx
+ - $(FIND) $(TARGET_DIR) -type f -not -perm /0100 -not -name 'ssh_host*' -not -name 'shadow' -print0 | $(XARGS) -0 chmod u+rw,g+r,o+r
+ - $(FIND) $(TARGET_DIR) -type f -perm /0100 -print0 | $(XARGS) -0 chmod u+rwx,g+rx,o+rx
- $(FIND) $(TARGET_DIR) -type d -print0 | $(XARGS) -0 chmod u+rwx,g+rx,o+rx
$(INSTALL_DIR) $(TARGET_DIR)/tmp $(TARGET_DIR)/overlay
chmod 1777 $(TARGET_DIR)/tmp