aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-25 07:28:57 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-25 07:48:43 +0100
commit1e14f01ed6d0cfff962c633bf130e96964c13e43 (patch)
tree5e527607c44d3e5abec57fd4c2bede87207f4ba6 /include
parent1a83d4d30ff700d0e77252bbfd6bf8bdf11fac27 (diff)
downloadupstream-1e14f01ed6d0cfff962c633bf130e96964c13e43.tar.gz
upstream-1e14f01ed6d0cfff962c633bf130e96964c13e43.tar.bz2
upstream-1e14f01ed6d0cfff962c633bf130e96964c13e43.zip
u-boot.mk: add UBOOT_MAKE_FLAGS variable similar to MAKE_FLAGS
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include')
-rw-r--r--include/u-boot.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/u-boot.mk b/include/u-boot.mk
index 4993eb6a06..de62923352 100644
--- a/include/u-boot.mk
+++ b/include/u-boot.mk
@@ -76,7 +76,8 @@ DTC=$(wildcard $(LINUX_DIR)/scripts/dtc/dtc)
define Build/Compile/U-Boot
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
CROSS_COMPILE=$(TARGET_CROSS) \
- $(if $(DTC),DTC="$(DTC)")
+ $(if $(DTC),DTC="$(DTC)") \
+ $(UBOOT_MAKE_FLAGS)
endef
define BuildPackage/U-Boot/Defaults