aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2021-06-10 14:01:04 +0200
committerFelix Fietkau <nbd@nbd.name>2021-06-12 10:46:39 +0200
commit0c7c24d40aedcee25d5243e25a87d38246be128b (patch)
tree88cf429cac7e8a0e467e9cf76cdc94f254ec28ea /include
parent09de28090cfb3fb605e6f4b452503a4ec2c6c43f (diff)
downloadupstream-0c7c24d40aedcee25d5243e25a87d38246be128b.tar.gz
upstream-0c7c24d40aedcee25d5243e25a87d38246be128b.tar.bz2
upstream-0c7c24d40aedcee25d5243e25a87d38246be128b.zip
build: use ninja for cmake packages by default
Speed goes from: Executed in 178.08 secs fish external usr time 20.16 mins 509.00 micros 20.16 mins sys time 2.88 mins 39.00 micros 2.88 mins To: Executed in 175.90 secs fish external usr time 20.19 mins 0.00 micros 20.19 mins sys time 2.85 mins 497.00 micros 2.85 mins Tested with "time make -j 12" on AMD Ryzen 3600 When building individual packages, the build time difference is often significantly bigger than that. Signed-off-by: Felix Fietkau <nbd@nbd.name> Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'include')
-rw-r--r--include/cmake.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/cmake.mk b/include/cmake.mk
index 8a1c4fc4d5..7ccd872365 100644
--- a/include/cmake.mk
+++ b/include/cmake.mk
@@ -1,5 +1,7 @@
cmake_bool = $(patsubst %,-D%:BOOL=$(if $($(1)),ON,OFF),$(2))
+PKG_USE_NINJA ?= 1
+HOST_USE_NINJA ?= 1
ifeq ($(PKG_USE_NINJA),1)
PKG_BUILD_PARALLEL ?= 1
endif