aboutsummaryrefslogtreecommitdiffstats
path: root/include/uclibc++.mk
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-12-05 01:21:05 -0800
committerPaul Spooren <mail@aparcar.org>2020-12-07 10:46:43 -1000
commitf7d7a3a18b1f1d1fdcf5b05f4ab1af6b8fc2ce1e (patch)
tree06bcfcd5c08d28b5c5e96800e782662fbafd61d1 /include/uclibc++.mk
parent0ba83a757728185eabd965e07331508923cca825 (diff)
downloadupstream-f7d7a3a18b1f1d1fdcf5b05f4ab1af6b8fc2ce1e.tar.gz
upstream-f7d7a3a18b1f1d1fdcf5b05f4ab1af6b8fc2ce1e.tar.bz2
upstream-f7d7a3a18b1f1d1fdcf5b05f4ab1af6b8fc2ce1e.zip
libcxx[abi]: remove
This is a neat project, but offers no benefit to OpenWrt. The initial reason for it was to be a replacement for libstdcpp as it is smaller and lacks compatibility for C++98. Unfortunately, compiling several packages with it results in larger ipk sizes. While not a member of the packages feed, this will be moved to packages-abandoned to keep it somewhere. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'include/uclibc++.mk')
-rw-r--r--include/uclibc++.mk12
1 files changed, 2 insertions, 10 deletions
diff --git a/include/uclibc++.mk b/include/uclibc++.mk
index 27533279c9..a1a61f26d4 100644
--- a/include/uclibc++.mk
+++ b/include/uclibc++.mk
@@ -4,8 +4,8 @@ ifndef DUMP
endif
endif
-PKG_PREPARED_DEPENDS += CONFIG_USE_UCLIBCXX CONFIG_USE_LIBCXX
-CXX_DEPENDS = +USE_UCLIBCXX:uclibcxx +USE_LIBCXX:libcxx +USE_LIBSTDCXX:libstdcpp
+PKG_PREPARED_DEPENDS += CONFIG_USE_UCLIBCXX
+CXX_DEPENDS = +USE_UCLIBCXX:uclibcxx +USE_LIBSTDCXX:libstdcpp
ifneq ($(CONFIG_USE_UCLIBCXX),)
ifneq ($(CONFIG_CCACHE),)
@@ -14,11 +14,3 @@ ifneq ($(CONFIG_USE_UCLIBCXX),)
TARGET_CXX=g++-uc
endif
endif
-
-ifneq ($(CONFIG_USE_LIBCXX),)
- ifneq ($(CONFIG_CCACHE),)
- TARGET_CXX_NOCACHE=g++-libcxx
- else
- TARGET_CXX=g++-libcxx
- endif
-endif