aboutsummaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2020-04-17 20:57:06 -0300
committerPetr Štetiar <ynezz@true.cz>2020-05-20 17:03:45 +0200
commitf827f947aed2d6395eb33ffc36863561145ea420 (patch)
tree8e3a6445b58238e9535281992251def8caee3983 /include/toplevel.mk
parent1f2539a1f48b37b3aa99efba6bcef7cc2030793a (diff)
downloadupstream-f827f947aed2d6395eb33ffc36863561145ea420.tar.gz
upstream-f827f947aed2d6395eb33ffc36863561145ea420.tar.bz2
upstream-f827f947aed2d6395eb33ffc36863561145ea420.zip
build: show make output in scripts/config when V=s
This should make debugging build errors in scripts/config a bit easier. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 2965f75c7c..ad8e5b8f20 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -104,7 +104,8 @@ scripts/config/%onf: export PATH:=$(dir $(DISTRO_PKG_CONFIG)):$(PATH)
endif
scripts/config/%onf: CFLAGS+= -O2
scripts/config/%onf:
- @$(_SINGLE)$(SUBMAKE) -s -C scripts/config $(notdir $@) CC="$(HOSTCC_WRAPPER)"
+ @$(_SINGLE)$(SUBMAKE) $(if $(findstring s,$(OPENWRT_VERBOSE)),,-s) \
+ -C scripts/config $(notdir $@) CC="$(HOSTCC_WRAPPER)"
$(eval $(call rdep,scripts/config,scripts/config/mconf))