aboutsummaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-04-03 12:36:35 +0200
committerFelix Fietkau <nbd@nbd.name>2017-04-12 09:53:06 +0200
commitb044bd5921e9644c9df9655bef10cee0af730724 (patch)
tree0ed247e6061c48a7f2626c5c6ab9b11344434f9b /include/toplevel.mk
parenta7f8564b0fe358e04b03e87566e8be54c2e48c9b (diff)
downloadupstream-b044bd5921e9644c9df9655bef10cee0af730724.tar.gz
upstream-b044bd5921e9644c9df9655bef10cee0af730724.tar.bz2
upstream-b044bd5921e9644c9df9655bef10cee0af730724.zip
build: remove package makefile overlay functionality
Recent attempts to use it have shown that it does not work properly except for a few undocumented cases. It's better to remove this now to avoid having more people fall into the same trap Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 0f68580955..ceafffb3a7 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -81,7 +81,7 @@ _ignore = $(foreach p,$(IGNORE_PACKAGES),--ignore $(p))
prepare-tmpinfo: FORCE
@+$(MAKE) -r -s staging_dir/host/.prereq-build $(PREP_MK)
mkdir -p tmp/info
- $(_SINGLE)$(NO_TRACE_MAKE) -j1 -r -s -f include/scan.mk SCAN_TARGET="packageinfo" SCAN_DIR="package" SCAN_NAME="package" SCAN_DEPS="$(TOPDIR)/include/package*.mk $(TOPDIR)/overlay/*/*.mk" SCAN_DEPTH=5 SCAN_EXTRA=""
+ $(_SINGLE)$(NO_TRACE_MAKE) -j1 -r -s -f include/scan.mk SCAN_TARGET="packageinfo" SCAN_DIR="package" SCAN_NAME="package" SCAN_DEPS="$(TOPDIR)/include/package*.mk" SCAN_DEPTH=5 SCAN_EXTRA=""
$(_SINGLE)$(NO_TRACE_MAKE) -j1 -r -s -f include/scan.mk SCAN_TARGET="targetinfo" SCAN_DIR="target/linux" SCAN_NAME="target" SCAN_DEPS="image/Makefile profiles/*.mk $(TOPDIR)/include/kernel*.mk $(TOPDIR)/include/target.mk" SCAN_DEPTH=2 SCAN_EXTRA="" SCAN_MAKEOPTS="TARGET_BUILD=1"
for type in package target; do \
f=tmp/.$${type}info; t=tmp/.config-$${type}.in; \