aboutsummaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-02-20 14:24:54 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-26 13:31:44 +0100
commit9467ce42da7fbcec1a4b5b8e08e2dcea3c67aa96 (patch)
treec3d4f2ab3090a91a89fd731a2499aa341e3cc1e8 /include/toplevel.mk
parentbe206eba3a57128695a00f490767e5c136e43ab7 (diff)
downloadupstream-9467ce42da7fbcec1a4b5b8e08e2dcea3c67aa96.tar.gz
upstream-9467ce42da7fbcec1a4b5b8e08e2dcea3c67aa96.tar.bz2
upstream-9467ce42da7fbcec1a4b5b8e08e2dcea3c67aa96.zip
build: get rid of host.mk
Defined required host related variables in toplevel.mk instead Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index a9ea21bbef..0f68580955 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -24,6 +24,9 @@ export REVISION
export SOURCE_DATE_EPOCH
export GIT_CONFIG_PARAMETERS='core.autocrlf=false'
export MAKE_JOBSERVER=$(filter --jobserver%,$(MAKEFLAGS))
+export GNU_HOST_NAME:=$(shell $(TOPDIR)/scripts/config.guess)
+export HOST_OS:=$(shell uname)
+export HOST_ARCH:=$(shell uname -m)
# prevent perforce from messing with the patch utility
unexport P4PORT P4USER P4CONFIG P4CLIENT
@@ -148,7 +151,6 @@ kernel_nconfig: prepare_kernel_conf
staging_dir/host/.prereq-build: include/prereq-build.mk
mkdir -p tmp
- rm -f tmp/.host.mk
@$(_SINGLE)$(NO_TRACE_MAKE) -j1 -r -s -f $(TOPDIR)/include/prereq-build.mk prereq 2>/dev/null || { \
echo "Prerequisite check failed. Use FORCE=1 to override."; \
false; \