aboutsummaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-14 15:36:39 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-17 10:36:25 +0100
commit7a315b0b5d6aa91695853a8647383876e4b49a7a (patch)
treeca99d91b9ec9408e37d30f2983847fc5a500d4a7 /include/toplevel.mk
parent720b99215da295a2e7b4acdef30b58bec6acedc2 (diff)
downloadupstream-7a315b0b5d6aa91695853a8647383876e4b49a7a.tar.gz
upstream-7a315b0b5d6aa91695853a8647383876e4b49a7a.tar.bz2
upstream-7a315b0b5d6aa91695853a8647383876e4b49a7a.zip
build: implement make check and make package/X/check
This is intended to be used for a wide array of package sanity checks. The first check that is implemented is for the hash of downloaded files. It checks: - Missing hash - Use of SHA256 instead of MD5 - dl/<file> hash not matching hash in makefile - deprecated MD5SUM variable The deprecated MD5SUM variable check is skipped for feeds/ until OpenWrt is updated as well Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index f31884d3fe..5e99df8d9e 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -179,6 +179,9 @@ clean dirclean: .config
prereq:: prepare-tmpinfo .config
@+$(NO_TRACE_MAKE) -r -s $@
+check: .config FORCE
+ @+$(NO_TRACE_MAKE) -r -s $@ QUIET= V=s
+
WARN_PARALLEL_ERROR = $(if $(BUILD_LOG),,$(and $(filter -j,$(MAKEFLAGS)),$(findstring s,$(OPENWRT_VERBOSE))))
ifeq ($(SDK),1)