aboutsummaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2020-04-07 17:07:24 -0300
committerPetr Štetiar <ynezz@true.cz>2020-04-09 12:51:10 +0200
commit3204430e38f1a2ba7fda9471720a2a1042adf5e0 (patch)
tree09c37c01356709c5596609e22616f7d9f208a79c /include/toplevel.mk
parentdcf3e63a35d05e7e5103819c0f17195bfafe9baa (diff)
downloadupstream-3204430e38f1a2ba7fda9471720a2a1042adf5e0.tar.gz
upstream-3204430e38f1a2ba7fda9471720a2a1042adf5e0.tar.bz2
upstream-3204430e38f1a2ba7fda9471720a2a1042adf5e0.zip
build: add option to warn on recursive dependency
This addes the option to treat recursive dependencies as warnings instead of errors, by running make with WARN_RECURSIVE_DEP=1. Note that the script/config targets will not get rebuilt when you add or remove WARN_RECURSIVE_DEP while running make. One must run 'make config-clean' before building config with a different setting. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 2965f75c7c..def80503dd 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -102,7 +102,7 @@ prepare-tmpinfo: FORCE
ifneq ($(DISTRO_PKG_CONFIG),)
scripts/config/%onf: export PATH:=$(dir $(DISTRO_PKG_CONFIG)):$(PATH)
endif
-scripts/config/%onf: CFLAGS+= -O2
+scripts/config/%onf: CFLAGS+= -O2 $(if $(WARN_RECURSIVE_DEP),-DWARN_RECURSIVE_DEP)
scripts/config/%onf:
@$(_SINGLE)$(SUBMAKE) -s -C scripts/config $(notdir $@) CC="$(HOSTCC_WRAPPER)"