aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-24 13:11:43 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-24 13:15:01 +0100
commitf4f8f4a180366ee90fd8e153213db2cb746ca361 (patch)
tree5438874a6f1b410eddf14a0ee54fbf0be42a91d6 /include/target.mk
parent94b6dc3a435bfaebb12b7326194a92a485fa070a (diff)
downloadupstream-f4f8f4a180366ee90fd8e153213db2cb746ca361.tar.gz
upstream-f4f8f4a180366ee90fd8e153213db2cb746ca361.tar.bz2
upstream-f4f8f4a180366ee90fd8e153213db2cb746ca361.zip
x86: unify CPU_TYPE for legacy and geode
According to some reports, -march=pentium-mmx is a better choice for older Geode CPUs than -march=geode anyway. Bump the minimum architecture of the legacy target from i486 to pentium-mmx. Anything older is not worth supporting anyway. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/include/target.mk b/include/target.mk
index 597563d5ec..30994485e1 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -170,10 +170,9 @@ ifeq ($(DUMP),1)
CPU_CFLAGS_octeon = -march=octeon -mabi=64
endif
ifeq ($(ARCH),i386)
- CPU_TYPE ?= i486
- CPU_CFLAGS_i486 = -march=i486
+ CPU_TYPE ?= pentium
+ CPU_CFLAGS_pentium = -march=pentium-mmx
CPU_CFLAGS_pentium4 = -march=pentium4
- CPU_CFLAGS_geode = -march=geode -mmmx -m3dnow
endif
ifneq ($(findstring arm,$(ARCH)),)
CPU_TYPE ?= xscale