aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2020-07-07 10:32:09 +0200
committerDavid Bauer <mail@david-bauer.net>2020-07-07 10:32:09 +0200
commitcf6f01c0e69a31afc6c5f384405ace51e03fe481 (patch)
treef3a102a1abe2c7b1b70b7c25f58e8448f9c83dc4 /include/target.mk
parentf496939f15b07c3386769491f7e4beb16b072240 (diff)
downloadupstream-cf6f01c0e69a31afc6c5f384405ace51e03fe481.tar.gz
upstream-cf6f01c0e69a31afc6c5f384405ace51e03fe481.tar.bz2
upstream-cf6f01c0e69a31afc6c5f384405ace51e03fe481.zip
build: conditionally enable testing-kernel feature
Only enable the testing-kernel feature for the target when the testing kernel version does not match the stable kernel version. This way, the option for building the testing kernel in the build config menu is only exposed when there's a testing kernel available. Signed-off-by: David Bauer <mail@david-bauer.net> Acked-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/target.mk b/include/target.mk
index a2ceb7f783..64292138b7 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -223,7 +223,9 @@ ifeq ($(DUMP),1)
.PRECIOUS: $(TMP_CONFIG)
ifdef KERNEL_TESTING_PATCHVER
- FEATURES += testing-kernel
+ ifneq ($(KERNEL_TESTING_PATCHVER),$(KERNEL_PATCHVER))
+ FEATURES += testing-kernel
+ endif
endif
ifneq ($(CONFIG_OF),)
FEATURES += dt