aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-04-28 22:01:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-04-28 22:01:14 +0000
commit2448cb8a1587da880c525f9bd7e8c029bb56f81f (patch)
tree7503cac1d598858ea363c10317735a914074ec25 /include/target.mk
parent19cb0b369307d45b9fc49ca1e6ad3762e95109d8 (diff)
downloadupstream-2448cb8a1587da880c525f9bd7e8c029bb56f81f.tar.gz
upstream-2448cb8a1587da880c525f9bd7e8c029bb56f81f.tar.bz2
upstream-2448cb8a1587da880c525f9bd7e8c029bb56f81f.zip
add optional version suffix to kernel files/ directories
SVN-Revision: 10972
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index ce842da795..7010424b43 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -106,6 +106,7 @@ include $(INCLUDE_DIR)/kernel-version.mk
GENERIC_PLATFORM_DIR := $(TOPDIR)/target/linux/generic-$(KERNEL)
GENERIC_PATCH_DIR := $(GENERIC_PLATFORM_DIR)/patches$(shell [ -d "$(GENERIC_PLATFORM_DIR)/patches-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
+GENERIC_FILES_DIR := $(GENERIC_PLATFORM_DIR)/files$(shell [ -d "$(GENERIC_PLATFORM_DIR)/files-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
GENERIC_LINUX_CONFIG?=$(firstword $(wildcard $(GENERIC_PLATFORM_DIR)/config-$(KERNEL_PATCHVER) $(GENERIC_PLATFORM_DIR)/config-default))
LINUX_CONFIG?=$(firstword $(wildcard $(foreach subdir,$(PLATFORM_DIR) $(PLATFORM_SUBDIR),$(subdir)/config-$(KERNEL_PATCHVER) $(subdir)/config-default)))