aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>2017-02-08 20:52:08 +0300
committerJohn Crispin <john@phrozen.org>2017-02-11 06:53:25 +0100
commit0799de6d9ec29fba460d286bd54818bdb7034702 (patch)
tree29bd5fa9c11688696d1d4f91c884684d3223617c /include/target.mk
parent84e784671bd3ce6f09fc1d7492125ae76f18215a (diff)
downloadupstream-0799de6d9ec29fba460d286bd54818bdb7034702.tar.gz
upstream-0799de6d9ec29fba460d286bd54818bdb7034702.tar.bz2
upstream-0799de6d9ec29fba460d286bd54818bdb7034702.zip
ARC: use -mcpu=XXX instead of obsolete -mXXX
-mXXX option is deprecated already in arc-2016.03 toolchain and removed completely starting from arc-2016.09. Direct replacement is -mcpu=XXX which is already supported by arc-2016.03 used today in Lede. With that change we'll be ready for ARC toolchain update still keeping everything working with current tools. Signed-off-by: Alexey Brodkin <Alexey.Brodkin@synopsys.com> Cc: John Crispin <john@phrozen.org>
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/target.mk b/include/target.mk
index 30994485e1..5490d4882f 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -215,8 +215,8 @@ ifeq ($(DUMP),1)
ifeq ($(ARCH),arc)
CPU_TYPE ?= arc700
CPU_CFLAGS += -matomic
- CPU_CFLAGS_arc700 = -marc700
- CPU_CFLAGS_archs = -marchs
+ CPU_CFLAGS_arc700 = -mcpu=arc700
+ CPU_CFLAGS_archs = -mcpu=archs
endif
DEFAULT_CFLAGS=$(strip $(CPU_CFLAGS) $(CPU_CFLAGS_$(CPU_TYPE)) $(CPU_CFLAGS_$(CPU_SUBTYPE)))