aboutsummaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-02-09 13:21:53 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-09 13:51:35 +0100
commitd826af2cbbc7ff9781d6b9fdde5866f6e6367ec6 (patch)
treeec6a6e8056f87951caf31eb9819fdc9e54b86507 /include/subdir.mk
parentda0b9110fc783245aaa88ae6ed28aa6d5fe1bdea (diff)
downloadupstream-d826af2cbbc7ff9781d6b9fdde5866f6e6367ec6.tar.gz
upstream-d826af2cbbc7ff9781d6b9fdde5866f6e6367ec6.tar.bz2
upstream-d826af2cbbc7ff9781d6b9fdde5866f6e6367ec6.zip
build: make <subdir>/install opt-in, use it for target/ only
Fixes buildbot errors on running make target/install or toolchain/install Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index 6bbf23a492..6db4eaa781 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -61,7 +61,7 @@ define subdir
$(call warn,$(1),d,D $(1))
$(foreach bd,$($(1)/builddirs),
$(call warn,$(1),d,BD $(1)/$(bd))
- $(foreach target,$(SUBTARGETS),
+ $(foreach target,$(SUBTARGETS) $($(1)/subtargets),
$(foreach btype,$(buildtypes-$(bd)),
$(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(btype)/$(target): $(if $(QUILT),,$($(1)/$(bd)/$(btype)/$(target)) $(call $(1)//$(btype)/$(target),$(1)/$(bd)/$(btype))))
$(call log_make,$(1)/$(bd),$(target),$(btype),$(filter-out __default,$(variant))) \
@@ -81,7 +81,7 @@ define subdir
)
)
)
- $(foreach target,$(SUBTARGETS),$(call subtarget,$(1),$(target)))
+ $(foreach target,$(SUBTARGETS) $($(1)/subtargets),$(call subtarget,$(1),$(target)))
endef
ifndef DUMP_TARGET_DB