aboutsummaryrefslogtreecommitdiffstats
path: root/include/subdir.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-22 17:40:29 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-22 17:40:31 +0100
commit0e22d6377569cea4ba00b81d6ec64a1582a2cea4 (patch)
tree894de324de0abaf69607830fb5cebea34f1c12d6 /include/subdir.mk
parent34ec245662766354ce0d19d586bb08f220ddb3b3 (diff)
downloadupstream-0e22d6377569cea4ba00b81d6ec64a1582a2cea4.tar.gz
upstream-0e22d6377569cea4ba00b81d6ec64a1582a2cea4.tar.bz2
upstream-0e22d6377569cea4ba00b81d6ec64a1582a2cea4.zip
build: fix CONFIG_AUTOREMOVE for packages with multiple variants
Calling the clean target removes all .ipk files and un-stages the package. Add a new target just for clearing the build dir and call that one instead of the full clean target Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/subdir.mk')
-rw-r--r--include/subdir.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index e76a01e18a..6bbf23a492 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -52,7 +52,7 @@ rebuild_check = \
$(if $(BUILD_LOG),mkdir -p $(BUILD_LOG_DIR)/$(1)$(if $(4),/$(4));) \
$$(NO_TRACE_MAKE) $(if $(BUILD_LOG),-d) -q $(subdir_make_opts) .$(if $(3),$(3)-)$(2) \
> $(if $(BUILD_LOG),$(BUILD_LOG_DIR)/$(1)$(if $(4),/$(4))/check-$(if $(3),$(3)-)$(2).txt,/dev/null) 2>&1 || \
- $$(SUBMAKE) $(subdir_make_opts) clean >/dev/null 2>/dev/null
+ $$(SUBMAKE) $(subdir_make_opts) clean-build >/dev/null 2>/dev/null
endif