aboutsummaryrefslogtreecommitdiffstats
path: root/include/rootfs.mk
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-03-06 21:06:30 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-03-07 09:59:07 +0100
commitcf1c7c0f17a45bba3e7ce1a3cd3f8f7efa7196c4 (patch)
tree1ebdd028994df38f302205f22dd849bfab2eb981 /include/rootfs.mk
parent6ab50bb10ded770f023e14d63cac2522076f9daf (diff)
downloadupstream-cf1c7c0f17a45bba3e7ce1a3cd3f8f7efa7196c4.tar.gz
upstream-cf1c7c0f17a45bba3e7ce1a3cd3f8f7efa7196c4.tar.bz2
upstream-cf1c7c0f17a45bba3e7ce1a3cd3f8f7efa7196c4.zip
include/rootfs.mk: pass additional files dir to prepare_rootfs as an argument
Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'include/rootfs.mk')
-rw-r--r--include/rootfs.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/rootfs.mk b/include/rootfs.mk
index a3a08c2851..bf26dd2415 100644
--- a/include/rootfs.mk
+++ b/include/rootfs.mk
@@ -63,9 +63,9 @@ ifdef CONFIG_CLEAN_IPKG
endif
define prepare_rootfs
- @if [ -d $(TOPDIR)/files ]; then \
- $(call file_copy,$(TOPDIR)/files/.,$(1)); \
- fi
+ $(if $(2),@if [ -d '$(2)' ]; then \
+ $(call file_copy,$(2)/.,$(1)); \
+ fi)
@mkdir -p $(1)/etc/rc.d
@mkdir -p $(1)/var/lock
@( \