aboutsummaryrefslogtreecommitdiffstats
path: root/include/quilt.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-05-03 23:33:59 +0200
committerFelix Fietkau <nbd@nbd.name>2017-05-25 19:01:07 +0200
commit36ba6237d6e3a23fbeadcc1812a892faa4b07cbe (patch)
tree834d5fb060ca2441af84a7c1199fa11e768df41d /include/quilt.mk
parent221f32378292efb01306e3335bff458e0d234693 (diff)
downloadupstream-36ba6237d6e3a23fbeadcc1812a892faa4b07cbe.tar.gz
upstream-36ba6237d6e3a23fbeadcc1812a892faa4b07cbe.tar.bz2
upstream-36ba6237d6e3a23fbeadcc1812a892faa4b07cbe.zip
build: fix quilt for mixed package/host builds
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/quilt.mk')
-rw-r--r--include/quilt.mk47
1 files changed, 24 insertions, 23 deletions
diff --git a/include/quilt.mk b/include/quilt.mk
index 2115e26adc..03d19bf39c 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -4,12 +4,33 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
-ifneq ($(if $(DUMP),1,$(__quilt_inc)),1)
-__quilt_inc:=1
-
ifeq ($(TARGET_BUILD),1)
PKG_BUILD_DIR:=$(LINUX_DIR)
endif
+
+ifneq ($(PKG_BUILD_DIR),)
+ QUILT?=$(if $(wildcard $(PKG_BUILD_DIR)/.quilt_used),y)
+ ifneq ($(QUILT),)
+ STAMP_CHECKED:=$(PKG_BUILD_DIR)/.quilt_checked
+ override CONFIG_AUTOREBUILD=
+ override CONFIG_AUTOREMOVE=
+ quilt-check: $(STAMP_CHECKED)
+ endif
+endif
+
+ifneq ($(HOST_BUILD_DIR),)
+ HOST_QUILT?=$(if $(findstring command,$(origin QUILT)),$(QUILT),$(if $(wildcard $(HOST_BUILD_DIR)/.quilt_used),y))
+ ifneq ($(HOST_QUILT),)
+ HOST_STAMP_CHECKED:=$(HOST_BUILD_DIR)/.quilt_checked
+ override CONFIG_AUTOREBUILD=
+ override CONFIG_AUTOREMOVE=
+ host-quilt-check: $(HOST_STAMP_CHECKED)
+ endif
+endif
+
+ifneq ($(if $(DUMP),1,$(__quilt_inc)),1)
+__quilt_inc:=1
+
PATCH_DIR?=./patches
FILES_DIR?=./files
HOST_PATCH_DIR?=$(PATCH_DIR)
@@ -59,26 +80,6 @@ define HostPatchDir
$(call PatchDir/$(if $(strip $(HOST_QUILT)),Quilt,Default),$(strip $(1)),$(strip $(2)),$(strip $(3)))
endef
-ifneq ($(PKG_BUILD_DIR),)
- QUILT?=$(if $(wildcard $(PKG_BUILD_DIR)/.quilt_used),y)
- ifneq ($(QUILT),)
- STAMP_CHECKED:=$(PKG_BUILD_DIR)/.quilt_checked
- override CONFIG_AUTOREBUILD=
- override CONFIG_AUTOREMOVE=
- quilt-check: $(STAMP_CHECKED)
- endif
-endif
-
-ifneq ($(HOST_BUILD_DIR),)
- HOST_QUILT?=$(if $(findstring command,$(origin QUILT)),$(QUILT),$(if $(wildcard $(HOST_BUILD_DIR)/.quilt_used),y))
- ifneq ($(HOST_QUILT),)
- HOST_STAMP_CHECKED:=$(HOST_BUILD_DIR)/.quilt_checked
- override CONFIG_AUTOREBUILD=
- override CONFIG_AUTOREMOVE=
- host-quilt-check: $(HOST_STAMP_CHECKED)
- endif
-endif
-
define Host/Patch/Default
$(if $(HOST_QUILT),rm -rf $(HOST_BUILD_DIR)/patches; mkdir -p $(HOST_BUILD_DIR)/patches)
$(call HostPatchDir,$(HOST_BUILD_DIR),$(HOST_PATCH_DIR),)