aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2023-04-20 12:31:16 -0400
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-04 06:07:23 +0200
commitffd7c05aa72ee56b836903159540f9470aeef121 (patch)
tree0d028215e58aa93d2d2a9ea4271dd1d373136daf /include/prereq-build.mk
parent0c117e1f6ccbee684ea0589d9024ca9dec4679c9 (diff)
downloadupstream-ffd7c05aa72ee56b836903159540f9470aeef121.tar.gz
upstream-ffd7c05aa72ee56b836903159540f9470aeef121.tar.bz2
upstream-ffd7c05aa72ee56b836903159540f9470aeef121.zip
prereq-build: add check for true and false
Some uses cases, like with autotools, need a path for 'true' if we use them to force something to skip. This will work by default on Linux hosts, and require MacOS hosts to get coreutils, which is currently installed in the CI for 'macos-latest' host. In the future, prereq stage can be reworked to search for the actual binary instead of relying on env. Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 8fae92ab97..14a2210880 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -8,6 +8,13 @@ include $(INCLUDE_DIR)/prereq.mk
SHELL:=sh
PKG_NAME:=Build dependency
+$(eval $(call TestHostCommand,true, \
+ Please install GNU 'coreutils', \
+ $(TRUE)))
+
+$(eval $(call TestHostCommand,false, \
+ Please install GNU 'coreutils', \
+ $(FALSE); [ $$$$$$$$? = 1 ] && $(TRUE)))
# Required for the toolchain
$(eval $(call TestHostCommand,working-make, \