aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-25 13:20:38 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-05 11:09:12 +0100
commitf6e6341d896adb78f9b496f71aab8f45e1742d5a (patch)
treebc4cd06f9a10e5e94c624bdcd374f41ac13a92ff /include/prereq-build.mk
parenta46c9a4038f385e53b49b42a1e195b1fc3261842 (diff)
downloadupstream-f6e6341d896adb78f9b496f71aab8f45e1742d5a.tar.gz
upstream-f6e6341d896adb78f9b496f71aab8f45e1742d5a.tar.bz2
upstream-f6e6341d896adb78f9b496f71aab8f45e1742d5a.zip
tools: build libressl on all systems
Useful for having a more consistent build environment and finding API issues faster Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk14
1 files changed, 0 insertions, 14 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index ed652ca9a7..29b6fbdaa6 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -75,14 +75,6 @@ $(eval $(call TestHostCommand,zlib, \
echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
gcc -include zlib.h -x c -o $(TMP_DIR)/a.out - $(zlib_link_flags)))
-# Xcode deprecated openssl, MacPorts doesn't work nicely for other packages
-ifneq ($(HOST_OS),Darwin)
-$(eval $(call TestHostCommand,libssl, \
- Please install the openssl library (with development headers), \
- echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
- gcc $(HOST_CFLAGS) -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl $(HOST_LDFLAGS)))
-endif
-
$(eval $(call TestHostCommand,perl-thread-queue, \
Please install the Perl Thread::Queue module, \
perl -MThread::Queue -e 1))
@@ -164,12 +156,6 @@ $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
$(eval $(call SetupHostCommand,file,Please install the 'file' package, \
file --version 2>&1 | grep file))
-ifneq ($(HOST_OS),Darwin)
-$(eval $(call SetupHostCommand,openssl,Please install the 'openssl' utility, \
- openssl version | grep '\(OpenSSL\|LibreSSL\)'))
-endif
-
-
# Install ldconfig stub
$(eval $(call TestHostCommand,ldconfig-stub,Failed to install stub, \
touch $(STAGING_DIR_HOST)/bin/ldconfig && \