aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorThorsten Glaser <tg@mirbsd.org>2018-10-22 19:28:50 +0200
committerJo-Philipp Wich <jo@mein.io>2019-01-30 12:39:18 +0100
commitda5bee5345ce8f66eb36b8993b87b684e5cce614 (patch)
tree110a6b4b1beb47d6179c2c5bb64394ff74cee93e /include/prereq-build.mk
parenta1170936798e519776de605d6986ccb72f04cb06 (diff)
downloadupstream-da5bee5345ce8f66eb36b8993b87b684e5cce614.tar.gz
upstream-da5bee5345ce8f66eb36b8993b87b684e5cce614.tar.bz2
upstream-da5bee5345ce8f66eb36b8993b87b684e5cce614.zip
build: fix umask detection bashism
the leading 0 is optional and not emitted by some shells Signed-off-by: Thorsten Glaser <tg@mirbsd.org>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index a416a2d232..f7da916f64 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -24,7 +24,7 @@ $(eval $(call TestHostCommand,case-sensitive-fs, \
$(eval $(call TestHostCommand,proper-umask, \
Please build with umask 022 - other values produce broken packages, \
- umask | grep -xE 00[012][012]))
+ umask | grep -xE 0?0[012][012]))
$(eval $(call SetupHostCommand,gcc, \
Please install the GNU C Compiler (gcc) 4.8 or later, \