aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-12-29 18:19:08 -1000
committerPaul Spooren <mail@aparcar.org>2020-12-31 09:30:01 -1000
commitcc9d5b5a488d3a43068f621a1ef184f06e43bede (patch)
treec8d32d80ff505271e3e3746f7a6d9460b76393fd /include/prereq-build.mk
parente1851720f10a7706a3654b64585b622de6adcf3d (diff)
downloadupstream-cc9d5b5a488d3a43068f621a1ef184f06e43bede.tar.gz
upstream-cc9d5b5a488d3a43068f621a1ef184f06e43bede.tar.bz2
upstream-cc9d5b5a488d3a43068f621a1ef184f06e43bede.zip
build/prereq: merge ifndef IB block together
Multiple prereq checks are only required within the build system but not for the ImageBuilder. These checks are excluded by using ifndef IB. This commit merges the three ifndef IB blocks together. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk6
1 files changed, 1 insertions, 5 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 5045fabdfb..fb11a070a1 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -38,9 +38,7 @@ $(eval $(call TestHostCommand,working-gcc, \
it appears to be broken, \
echo 'int main(int argc, char **argv) { return 0; }' | \
gcc -x c -o $(TMP_DIR)/a.out -))
-endif
-ifndef IB
$(eval $(call SetupHostCommand,g++, \
Please install the GNU C++ Compiler (g++) 4.8 or later, \
$(CXX) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
@@ -53,14 +51,12 @@ $(eval $(call TestHostCommand,working-g++, \
echo 'int main(int argc, char **argv) { return 0; }' | \
g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \
$(TMP_DIR)/a.out))
-endif
-ifndef IB
$(eval $(call TestHostCommand,ncurses, \
Please install ncurses. (Missing libncurses.so or ncurses.h), \
echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses))
-endif
+endif # IB
ifeq ($(HOST_OS),Linux)
zlib_link_flags := -Wl,-Bstatic -lz -Wl,-Bdynamic