aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-10-04 14:05:56 +0200
committerJo-Philipp Wich <jo@mein.io>2016-10-04 14:07:37 +0200
commitbe6f836841300fc6e9c401946ad4e5384e178f89 (patch)
tree3aef23ee18bc2d1ff9d550f8b4409ae73a9efb09 /include/prereq-build.mk
parenta69e19d18ac0ebb3a715def18fed37026cae15af (diff)
downloadupstream-be6f836841300fc6e9c401946ad4e5384e178f89.tar.gz
upstream-be6f836841300fc6e9c401946ad4e5384e178f89.tar.bz2
upstream-be6f836841300fc6e9c401946ad4e5384e178f89.zip
include: relax umask check
For now we only want to ensure that the group permission mask is permissive enough to not clobber required permissions on the rootfs, so allow less strict masks as well. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index c3b88db627..4a0509ac00 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -26,7 +26,7 @@ $(eval $(call TestHostCommand,case-sensitive-fs, \
$(eval $(call TestHostCommand,proper-umask, \
Please build with umask 022 - other values produce broken packages, \
- umask | grep -xF 0022))
+ umask | grep -xE 00[012][012]))
$(eval $(call SetupHostCommand,gcc, \
Please install the GNU C Compiler (gcc), \