aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-03-15 21:23:31 +0300
committerJo-Philipp Wich <jo@mein.io>2019-10-18 19:48:49 +0200
commit9bb5dac5937698252ea0fc97c255aa7a6db0db84 (patch)
tree32743a414c64dc514570ea169255a155c94f5a81 /include/prereq-build.mk
parentc7c14aaad36bb3d12dbcc826904154a1bc73c713 (diff)
downloadupstream-9bb5dac5937698252ea0fc97c255aa7a6db0db84.tar.gz
upstream-9bb5dac5937698252ea0fc97c255aa7a6db0db84.tar.bz2
upstream-9bb5dac5937698252ea0fc97c255aa7a6db0db84.zip
build: fix seq host tool check
Problem found on alpine linux when trying to `./scripts/feeds update -a`, which results in `Build dependency: Missing seq command`. Ref: https://github.com/openwrt/openwrt/pull/1926 Suggested-by: imShara <shara@protonmail.com> [reworded commit and turned faulty Sob into Suggested-by] Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 0f2a35c93b..4c59910056 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -105,9 +105,9 @@ $(eval $(call SetupHostCommand,cp,Please install GNU fileutils, \
gcp --help 2>&1 | grep 'Copy SOURCE', \
cp --help 2>&1 | grep 'Copy SOURCE'))
-$(eval $(call SetupHostCommand,seq,, \
+$(eval $(call SetupHostCommand,seq,Please install seq, \
gseq --version, \
- seq --version))
+ seq --version 2>&1 | grep seq))
$(eval $(call SetupHostCommand,awk,Please install GNU 'awk', \
gawk --version 2>&1 | grep GNU, \