aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-04-15 19:24:02 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2018-04-28 15:28:59 +0200
commit8dcd941d8b934891676a8d4bbef1ee78e89a4bf7 (patch)
tree8889465aa25467269f09f9b39ef9e5fe5a519fa0 /include/prereq-build.mk
parentafdca53acee25f452bd2c405cb3943db34492585 (diff)
downloadupstream-8dcd941d8b934891676a8d4bbef1ee78e89a4bf7.tar.gz
upstream-8dcd941d8b934891676a8d4bbef1ee78e89a4bf7.tar.bz2
upstream-8dcd941d8b934891676a8d4bbef1ee78e89a4bf7.zip
tools/zlib: move zlib build to tools
This allows us to link the other tools against our libz and we do not need the system zlib any more. Only the static linked library is copied to the staging directory so we have a statically linked library on all systems and not only on Linux. This also adds the new dependencies of the packages which are depending on zlib. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> Tested-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk5
1 files changed, 0 insertions, 5 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 6917716342..5b9a7e049d 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -76,11 +76,6 @@ else
zlib_link_flags := -lz
endif
-$(eval $(call TestHostCommand,zlib, \
- Please install a static zlib. (Missing libz.a or zlib.h), \
- echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
- gcc -include zlib.h -x c -o $(TMP_DIR)/a.out - $(zlib_link_flags)))
-
$(eval $(call TestHostCommand,perl-thread-queue, \
Please install the Perl Thread::Queue module, \
perl -MThread::Queue -e 1))