aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2020-08-06 12:53:14 +0200
committerFelix Fietkau <nbd@nbd.name>2020-08-06 13:17:13 +0200
commit6c29604438a0c2cbf95930244319c41d57756d7d (patch)
treec1297395fa9ca53d8523f02c1ac95c180a68bbd7 /include/prereq-build.mk
parentd1db1f4240c43d87ca898b885d1009120d0cc22d (diff)
downloadupstream-6c29604438a0c2cbf95930244319c41d57756d7d.tar.gz
upstream-6c29604438a0c2cbf95930244319c41d57756d7d.tar.bz2
upstream-6c29604438a0c2cbf95930244319c41d57756d7d.zip
build: set up host command for egrep
It is used for the kernel build and uses GNU specific features Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 83dad0f2dc..4637c6ca50 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -114,6 +114,10 @@ $(eval $(call SetupHostCommand,grep,Please install GNU 'grep', \
ggrep --version 2>&1 | grep GNU, \
grep --version 2>&1 | grep GNU))
+$(eval $(call SetupHostCommand,egrep,Please install GNU 'grep', \
+ gegrep --version 2>&1 | grep GNU, \
+ egrep --version 2>&1 | grep GNU))
+
$(eval $(call SetupHostCommand,getopt, \
Please install an extended getopt version that supports --long, \
gnugetopt -o t --long test -- --test | grep '^ *--test *--', \