aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorDamien Mascord <tusker@tusker.org>2021-11-01 20:06:20 +1100
committerBaptiste Jonglez <git@bitsofnetworks.org>2021-11-02 18:18:00 +0100
commit6a5b4228e30244b44a49f523dea66caf3fbe3307 (patch)
treedfded419c9c0456078b4bea7f9304a42a0f8766f /include/prereq-build.mk
parent605192f46c1576fe8abb3df6041d21c3f20e664a (diff)
downloadupstream-6a5b4228e30244b44a49f523dea66caf3fbe3307.tar.gz
upstream-6a5b4228e30244b44a49f523dea66caf3fbe3307.tar.bz2
upstream-6a5b4228e30244b44a49f523dea66caf3fbe3307.zip
build: fix ldconfig executable error in python
The empty executable is causing problems with meson builds, due to the error: OSError: [Errno 8] Exec format error: 'ldconfig' This patch changes the empty ldconfig stub to symlink to /bin/true to work around this issue. Fixes: FS#4117 Fixes: 3bd31cc4d2ff ("tools/meson: update to 0.60.0") Signed-off-by: Damien Mascord <tusker@tusker.org> Tested-by: Aleksander Jan Bajkowski <olek2@wp.pl> # Tested on Debian 11 Tested-By: Lucian Cristian <lucian.cristian@gmail.com> Tested-By: Baptiste Jonglez <git@bitsofnetworks.org> Cc: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index ce6873cf52..e1918f0027 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -198,5 +198,4 @@ prereq: $(STAGING_DIR_HOST)/bin/mkhash
# Install ldconfig stub
$(eval $(call TestHostCommand,ldconfig-stub,Failed to install stub, \
- touch $(STAGING_DIR_HOST)/bin/ldconfig && \
- chmod +x $(STAGING_DIR_HOST)/bin/ldconfig))
+ $(LN) /bin/true $(STAGING_DIR_HOST)/bin/ldconfig))