aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-10-04 11:04:50 +0200
committerJo-Philipp Wich <jo@mein.io>2016-10-04 11:08:58 +0200
commit5f80315634c66a647aed9673e10582acd8462d69 (patch)
tree3c8fffb37b46a42e9e1990ae2702591b62ce0f96 /include/prereq-build.mk
parentb8d802fe9f6ddf02d67e7d847904e7389715561e (diff)
downloadupstream-5f80315634c66a647aed9673e10582acd8462d69.tar.gz
upstream-5f80315634c66a647aed9673e10582acd8462d69.tar.bz2
upstream-5f80315634c66a647aed9673e10582acd8462d69.zip
include: add umask prereq check
When building LEDE with umask values other than 022, the resulting packages will embed improper permissions, which may lead to random errors or non- functional scripts on the target. In order to make users aware of this problem, add a build-prereq check to assert a correct umask setting before starting the build. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 9c0717d53a..c3b88db627 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -24,6 +24,10 @@ $(eval $(call TestHostCommand,case-sensitive-fs, \
rm -f $(TMP_DIR)/test.*; touch $(TMP_DIR)/test.fs; \
test ! -f $(TMP_DIR)/test.FS))
+$(eval $(call TestHostCommand,proper-umask, \
+ Please build with umask 022 - other values produce broken packages, \
+ umask | grep -xF 0022))
+
$(eval $(call SetupHostCommand,gcc, \
Please install the GNU C Compiler (gcc), \
$(CC) --version | grep gcc, \