aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-04-14 11:14:47 -1000
committerPetr Štetiar <ynezz@true.cz>2020-06-03 16:49:28 +0200
commit4a1a58a3e2d2360950ff23a05f1f55b779174d6a (patch)
tree417af06773b0adf00d3c4ed19f45785e2874374e /include/prereq-build.mk
parent0a182fcba6d9cb2cf74cae9114ea4770ef928f75 (diff)
downloadupstream-4a1a58a3e2d2360950ff23a05f1f55b779174d6a.tar.gz
upstream-4a1a58a3e2d2360950ff23a05f1f55b779174d6a.tar.bz2
upstream-4a1a58a3e2d2360950ff23a05f1f55b779174d6a.zip
build, imagebuilder: Do not require libncurses-dev
The buildroot and SDK both require `libncurses-dev` to be installed on the system, however the ImageBuilder uses precompiled binaries. This patch changes the prerequirements checks to skip the `libncurses-dev` part if running as ImageBuilder. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index f4fa592a7f..83dad0f2dc 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -51,10 +51,12 @@ $(eval $(call TestHostCommand,working-g++, \
g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \
$(TMP_DIR)/a.out))
+ifndef IB
$(eval $(call TestHostCommand,ncurses, \
Please install ncurses. (Missing libncurses.so or ncurses.h), \
echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses))
+endif
ifeq ($(HOST_OS),Linux)
zlib_link_flags := -Wl,-Bstatic -lz -Wl,-Bdynamic