aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2020-03-24 11:05:27 +0000
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2020-03-24 14:42:52 +0000
commit1fb3c003d68d3feaf797e8b64edccc9fa622d250 (patch)
tree3b024ba9c744513fe8a60679fd998540d034d7eb /include/prereq-build.mk
parent9b0290ffbd16d324fc195d039727c3920829b9f6 (diff)
downloadupstream-1fb3c003d68d3feaf797e8b64edccc9fa622d250.tar.gz
upstream-1fb3c003d68d3feaf797e8b64edccc9fa622d250.tar.bz2
upstream-1fb3c003d68d3feaf797e8b64edccc9fa622d250.zip
build: prereq: tidy gcc version checks
There is a restriction in the number of parameters(10) that may be passed to the SetupHostCommand macro so continually adding explicit gcc'n' version checks ends up breaking the compiler check for the later versions and oddballs like Darwin as was done in 835d1c68a0 which added gcc10. Drop all the explicitly specified gcc version checks. If a suitable gcc compiler is not found, it may be specified at the dependency checking stage after which that version will be symlinked into the build staging host directory. eg. 'CC=gccfoo CXX=g++foo make prereq' Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk> Acked-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk16
1 files changed, 0 insertions, 16 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 156b3f3722..830a9eff9a 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -30,14 +30,6 @@ $(eval $(call SetupHostCommand,gcc, \
Please install the GNU C Compiler (gcc) 4.8 or later, \
$(CC) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
gcc -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
- gcc48 --version | grep gcc, \
- gcc49 --version | grep gcc, \
- gcc5 --version | grep gcc, \
- gcc6 --version | grep gcc, \
- gcc7 --version | grep gcc, \
- gcc8 --version | grep gcc, \
- gcc9 --version | grep gcc, \
- gcc10 --version | grep gcc, \
gcc --version | grep -E 'Apple.(LLVM|clang)' ))
$(eval $(call TestHostCommand,working-gcc, \
@@ -50,14 +42,6 @@ $(eval $(call SetupHostCommand,g++, \
Please install the GNU C++ Compiler (g++) 4.8 or later, \
$(CXX) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
g++ -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
- g++48 --version | grep g++, \
- g++49 --version | grep g++, \
- g++5 --version | grep g++, \
- g++6 --version | grep g++, \
- g++7 --version | grep g++, \
- g++8 --version | grep g++, \
- g++9 --version | grep g++, \
- g++10 --version | grep g++, \
g++ --version | grep -E 'Apple.(LLVM|clang)' ))
$(eval $(call TestHostCommand,working-g++, \