aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-03 08:44:08 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-03 08:44:08 +0000
commite5e03321f9e942f75b8b150dc0bbdaba6b1c0c9b (patch)
treefffedadef32af75b894dcb9902f37de459a988e4 /include/package.mk
parentd8174a039855254d3912bae0484f03bb9d958d51 (diff)
downloadupstream-e5e03321f9e942f75b8b150dc0bbdaba6b1c0c9b.tar.gz
upstream-e5e03321f9e942f75b8b150dc0bbdaba6b1c0c9b.tar.bz2
upstream-e5e03321f9e942f75b8b150dc0bbdaba6b1c0c9b.zip
tweak Build/Compile/PyMod: add CPPFLAGS, allow caller to override any of the default *FLAGS, indent
SVN-Revision: 8590
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk14
1 files changed, 8 insertions, 6 deletions
diff --git a/include/package.mk b/include/package.mk
index 074c7aded1..0c8886c784 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -126,12 +126,14 @@ define Build/Compile
endef
define Build/Compile/PyMod
- cd $(PKG_BUILD_DIR); \
- $(1) \
- CFLAGS='-I$(STAGING_DIR)/usr/include' \
- LDFLAGS='$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib' \
- $(STAGING_DIR)/usr/bin/hostpython ./setup.py $(2) \
- --prefix=$(PKG_INSTALL_DIR)/usr
+ ( cd $(PKG_BUILD_DIR); \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ CPPFLAGS="$(TARGET_CPPFLAGS)" \
+ LDFLAGS="$(TARGET_LDFLAGS)" \
+ $(1) \
+ $(STAGING_DIR)/usr/bin/hostpython ./setup.py $(2) \
+ --prefix="$(PKG_INSTALL_DIR)/usr" \
+ )
endef
$(PACKAGE_DIR):