aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-24 13:55:52 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-24 13:55:55 +0100
commit807461e11c8e8d86f28fc642966eb1f83a3b08f1 (patch)
tree92562956f2a865d170bd13a52b58769bbfff94da /include/package.mk
parentad85464f11ee40ef1861d0a610ca4a3503835f9f (diff)
downloadupstream-807461e11c8e8d86f28fc642966eb1f83a3b08f1.tar.gz
upstream-807461e11c8e8d86f28fc642966eb1f83a3b08f1.tar.bz2
upstream-807461e11c8e8d86f28fc642966eb1f83a3b08f1.zip
build: make the touch .autoremove call non-fatal
Fixes build issues when there is nothing to do on the compile step (e.g. with unselected packages). Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package.mk b/include/package.mk
index 01c0333b06..91871f06fb 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -216,7 +216,7 @@ define Build/CoreTargets
ifneq ($(CONFIG_AUTOREMOVE),)
compile:
- touch $(PKG_BUILD_DIR)/.autoremove
+ -touch $(PKG_BUILD_DIR)/.autoremove 2>/dev/null >/dev/null
$(FIND) $(PKG_BUILD_DIR) -mindepth 1 -maxdepth 1 -not '(' -type f -and -name '.*' -and -size 0 ')' -and -not -name '.pkgdir' | \
$(XARGS) rm -rf
endif