aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-18 14:00:48 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-18 23:57:07 +0100
commit6cf067d084cc551c721e98b6d6c6403a63e521d5 (patch)
treecba95f698e521269aa3530791b758ac8f636d842 /include/package.mk
parentc99f8815680fb4abf42cbb2e9d1a909f8f373b02 (diff)
downloadupstream-6cf067d084cc551c721e98b6d6c6403a63e521d5.tar.gz
upstream-6cf067d084cc551c721e98b6d6c6403a63e521d5.tar.bz2
upstream-6cf067d084cc551c721e98b6d6c6403a63e521d5.zip
build: define common subdir targets in rules.mk
Reduce build system clutter and enable further rework Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk5
1 files changed, 1 insertions, 4 deletions
diff --git a/include/package.mk b/include/package.mk
index ea801288ea..62e538c594 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -143,6 +143,7 @@ Build/Exports=$(Build/Exports/Default)
define Build/CoreTargets
$(if $(QUILT),$(Build/Quilt))
$(call Build/Autoclean)
+ $(call DefaultTargets)
download:
$(foreach hook,$(Hooks/Download),
@@ -287,10 +288,6 @@ prepare-package-install:
$(PACKAGE_DIR):
mkdir -p $@
-dumpinfo:
-download:
-prepare:
-configure:
compile: prepare-package-install
install: compile