aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2017-12-10 15:30:30 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2017-12-28 12:24:25 +0100
commit307b29032fc357161505239cad794a99d07b69f4 (patch)
tree129d6a220e4b0ae93dfbaf7bca6b6f601c56d8af /include/package.mk
parent23bba9cb330cd298739a16e350b0029ed9429eef (diff)
downloadupstream-307b29032fc357161505239cad794a99d07b69f4.tar.gz
upstream-307b29032fc357161505239cad794a99d07b69f4.tar.bz2
upstream-307b29032fc357161505239cad794a99d07b69f4.zip
include/package.mk: remove old configured stamps before attempting configuration
Some packages, e.g. busybox, explicitly remove old .configured stamps before attempting configuration, rather than after the actual configuration step. This seems like a good idea, as there will be no stamp left if configuration fails. Change generic rules to work like this, so package- specific rules can be dropped. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package.mk b/include/package.mk
index e804b02b04..78ea5d0ef8 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -168,11 +168,11 @@ define Build/CoreTargets
$(call Build/Exports,$(STAMP_CONFIGURED))
$(STAMP_CONFIGURED): $(STAMP_PREPARED) $(STAMP_CONFIGURED_DEPENDS)
+ rm -f $(STAMP_CONFIGURED_WILDCARD)
$(CleanStaging)
$(foreach hook,$(Hooks/Configure/Pre),$(call $(hook))$(sep))
$(Build/Configure)
$(foreach hook,$(Hooks/Configure/Post),$(call $(hook))$(sep))
- rm -f $(STAMP_CONFIGURED_WILDCARD)
touch $$@
$(call Build/Exports,$(STAMP_BUILT))