aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-22 17:40:29 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-22 17:40:31 +0100
commit0e22d6377569cea4ba00b81d6ec64a1582a2cea4 (patch)
tree894de324de0abaf69607830fb5cebea34f1c12d6 /include/package.mk
parent34ec245662766354ce0d19d586bb08f220ddb3b3 (diff)
downloadupstream-0e22d6377569cea4ba00b81d6ec64a1582a2cea4.tar.gz
upstream-0e22d6377569cea4ba00b81d6ec64a1582a2cea4.tar.bz2
upstream-0e22d6377569cea4ba00b81d6ec64a1582a2cea4.zip
build: fix CONFIG_AUTOREMOVE for packages with multiple variants
Calling the clean target removes all .ipk files and un-stages the package. Add a new target just for clearing the build dir and call that one instead of the full clean target Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/include/package.mk b/include/package.mk
index 95b5f76dc3..fc2733907e 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -300,12 +300,14 @@ compile: prepare-package-install
.install: .compile
install: compile
-clean: FORCE
+clean-build: FORCE
+ rm -rf $(PKG_BUILD_DIR)
+
+clean: clean-build
$(CleanStaging)
$(call Build/UninstallDev,$(STAGING_DIR),$(STAGING_DIR_HOST))
$(Build/Clean)
rm -f $(STAGING_DIR)/packages/$(STAGING_FILES_LIST) $(STAGING_DIR_HOST)/packages/$(STAGING_FILES_LIST)
- rm -rf $(PKG_BUILD_DIR)
dist:
$(Build/Dist)