aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-18 14:27:04 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-18 23:57:08 +0100
commit9228d1c066cf3a2cd01288bed3646e53638705b6 (patch)
treee5e9af619fd75d10b58f4088191ca2adec64549c /include/package-ipkg.mk
parent6cf067d084cc551c721e98b6d6c6403a63e521d5 (diff)
downloadupstream-9228d1c066cf3a2cd01288bed3646e53638705b6.tar.gz
upstream-9228d1c066cf3a2cd01288bed3646e53638705b6.tar.bz2
upstream-9228d1c066cf3a2cd01288bed3646e53638705b6.zip
build: introduce extra targets that contain only proper dependencies
This can be used to check if targets like prepare or compile are up to date Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index e168eb390f..8727b4ec30 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -106,9 +106,9 @@ ifeq ($(DUMP),)
ifdef do_install
ifneq ($(CONFIG_PACKAGE_$(1))$(DEVELOPER),)
IPKGS += $(1)
- compile: $$(IPKG_$(1)) $(PKG_INFO_DIR)/$(1).provides $(STAGING_DIR_ROOT)/stamp/.$(1)_installed
+ .compile: $$(IPKG_$(1)) $(PKG_INFO_DIR)/$(1).provides $(STAGING_DIR_ROOT)/stamp/.$(1)_installed
ifneq ($(ABI_VERSION),)
- compile: $(PKG_INFO_DIR)/$(1).version
+ .compile: $(PKG_INFO_DIR)/$(1).version
endif
else
$(if $(CONFIG_PACKAGE_$(1)),$$(info WARNING: skipping $(1) -- package not selected))