aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2020-02-20 18:29:03 -0300
committerPetr Štetiar <ynezz@true.cz>2020-07-11 13:33:28 +0200
commit78d1f3ac61b1740f2a45c40bcde0e83246308a18 (patch)
treeefc2d706d92a09ad833fff49b46b080b30f0d282 /include/package-ipkg.mk
parent40acc13ca72ca7d2815dc5d94549d5dc48e16e98 (diff)
downloadupstream-78d1f3ac61b1740f2a45c40bcde0e83246308a18.tar.gz
upstream-78d1f3ac61b1740f2a45c40bcde0e83246308a18.tar.bz2
upstream-78d1f3ac61b1740f2a45c40bcde0e83246308a18.zip
build: call ipkg-remove using xargs if #args>=512
The wildcard call to clean up luci package (luci*) can pick up over 2,300 files when the full tree is built. Running make package/luci/clean or a second run of make package/luci/compile would fail with an 'Argument list too long' error. To avoid that, a maybe_use_xargs function was created that runs the command straight as usual if the number of arguments is < 512, or saves the list in a temporary file and feeds it to xargs otherwise. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk12
1 files changed, 11 insertions, 1 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index fa39c0927c..7fc0f86124 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -18,10 +18,20 @@ IPKG_REMOVE:= \
IPKG_STATE_DIR:=$(TARGET_DIR)/usr/lib/opkg
+# 1: command and initial arguments
+# 2: arguments list
+# 3: tmp filename
+define maybe_use_xargs
+ $(if $(word 512,$(2)), \
+ $(file >$(3),$(2)) $(XARGS) $(1) < "$(3)"; rm "$(3)", \
+ $(1) $(2))
+endef
+
# 1: package name
# 2: candidate ipk files
define remove_ipkg_files
- $(if $(strip $(2)),$(IPKG_REMOVE) $(1) $(2))
+ $(if $(strip $(2)), \
+ $(call maybe_use_xargs,$(IPKG_REMOVE) $(1),$(2),$(TMP_DIR)/$(1).in))
endef
# 1: package name