aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorJonas Gorski <jonas.gorski@gmail.com>2019-06-22 14:02:27 +0200
committerJonas Gorski <jonas.gorski@gmail.com>2019-06-25 14:42:07 +0200
commit5ede3fcdf74dcc1b1b4c9415152b2e8b26a45ead (patch)
tree96bd24bd2207f5676c2d74b5a47b2d927aece116 /include/package-ipkg.mk
parenta0e5ca4f3523b9eef96bff32e45f6fa8275b982f (diff)
downloadupstream-5ede3fcdf74dcc1b1b4c9415152b2e8b26a45ead.tar.gz
upstream-5ede3fcdf74dcc1b1b4c9415152b2e8b26a45ead.tar.bz2
upstream-5ede3fcdf74dcc1b1b4c9415152b2e8b26a45ead.zip
build: warn when packages have no associated install section
Declaring a package without the appropriate install section is an easy mistake to make, especially when renaming packages. Since this is also easy to detect, warn about it when it happens. Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com> No-objections-at-all-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 38252b95cd..442d3854f0 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -124,6 +124,8 @@ ifeq ($(DUMP),)
endif
$(PKG_INSTALL_STAMP).$(1): prepare-package-install
echo "$(1)" >> $(PKG_INSTALL_STAMP)
+ else
+ $(if $(CONFIG_PACKAGE_$(1)),$$(warning WARNING: skipping $(1) -- package has no install section))
endif
endif