aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2016-12-09 16:04:49 -0800
committerFlorian Fainelli <florian.fainelli@broadcom.com>2017-01-24 11:07:45 -0800
commit25e2cf392a7ff6c3ba6aee2ab1fa64d42f076776 (patch)
tree676bbf4bc8f0bdad7398eb530bd890d13d1b6609 /include/package-ipkg.mk
parent86ccaf4c18dabec9761e71a31d1456611cf1cdf9 (diff)
downloadupstream-25e2cf392a7ff6c3ba6aee2ab1fa64d42f076776.tar.gz
upstream-25e2cf392a7ff6c3ba6aee2ab1fa64d42f076776.tar.bz2
upstream-25e2cf392a7ff6c3ba6aee2ab1fa64d42f076776.zip
package-ipkg: Do not fail build without base-files
If the base-files package is not selected, we will fail executing the very first postinst script: make[3]: Leaving directory `/local/users/fainelli/openwrt/trunk' cp -fpR /local/users/fainelli/openwrt/trunk/build_dir/target-arm_xscale_musl-1.1.15_eabi/root-orion /local/users/fainelli/openwrt/trunk/build_dir/target-arm_xscale_musl-1.1.15_eabi/root.orig-orion ./usr/lib/opkg/info/busybox.postinst: line 3: /local/users/fainelli/openwrt/trunk/build_dir/target-arm_xscale_musl-1.1.15_eabi/root-orion/lib/functions.sh: No such file or directory ./usr/lib/opkg/info/busybox.postinst: line 4: default_postinst: command not found postinst script ./usr/lib/opkg/info/busybox.postinst has failed with exit code 127 make[2]: *** [package/install] Error 1 Check for the existence of lib/functions.sh, and if it does not exist, just bail out gracefully. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 3e2e31c789..b9d67f5604 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -207,11 +207,13 @@ $(_endef)
( \
echo "#!/bin/sh"; \
echo "[ \"\$$$${IPKG_NO_SCRIPT}\" = \"1\" ] && exit 0"; \
+ echo "[ -x "\$$$${IPKG_INSTROOT}/lib/functions.sh" ] || exit 0"; \
echo ". \$$$${IPKG_INSTROOT}/lib/functions.sh"; \
echo "default_postinst \$$$$0 \$$$$@"; \
) > postinst; \
( \
echo "#!/bin/sh"; \
+ echo "[ -x "\$$$${IPKG_INSTROOT}/lib/functions.sh" ] || exit 0"; \
echo ". \$$$${IPKG_INSTROOT}/lib/functions.sh"; \
echo "default_prerm \$$$$0 \$$$$@"; \
) > prerm; \