aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-ipkg.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-02-21 18:27:22 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-26 13:31:44 +0100
commit1f22957247caa85b9583ebb4edaee618dff4b3ba (patch)
treed8e3c8ad125a61f1c3a115ba9134af0ce61bd38a /include/package-ipkg.mk
parent9467ce42da7fbcec1a4b5b8e08e2dcea3c67aa96 (diff)
downloadupstream-1f22957247caa85b9583ebb4edaee618dff4b3ba.tar.gz
upstream-1f22957247caa85b9583ebb4edaee618dff4b3ba.tar.bz2
upstream-1f22957247caa85b9583ebb4edaee618dff4b3ba.zip
build: clean up redundant touching of the package install info file
Instead of using a separate .clean stamp file, remove the install info file on compile, then append the install package list afterwards Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/package-ipkg.mk')
-rw-r--r--include/package-ipkg.mk12
1 files changed, 4 insertions, 8 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 2b3ff148f5..620be991b3 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -107,22 +107,18 @@ ifeq ($(DUMP),)
ifneq ($(CONFIG_PACKAGE_$(1))$(DEVELOPER),)
IPKGS += $(1)
$(_pkg_target)compile: $$(IPKG_$(1)) $(PKG_INFO_DIR)/$(1).provides $(PKG_BUILD_DIR)/.pkgdir/$(1).installed
+ prepare-package-install: $$(IPKG_$(1))
compile: $(STAGING_DIR_ROOT)/stamp/.$(1)_installed
else
$(if $(CONFIG_PACKAGE_$(1)),$$(info WARNING: skipping $(1) -- package not selected))
endif
.PHONY: $(PKG_INSTALL_STAMP).$(1)
- compile: $(PKG_INSTALL_STAMP).$(1)
- $(PKG_INSTALL_STAMP).$(1):
- if [ -f $(PKG_INSTALL_STAMP).clean ]; then \
- rm -f \
- $(PKG_INSTALL_STAMP) \
- $(PKG_INSTALL_STAMP).clean; \
- fi
ifeq ($(CONFIG_PACKAGE_$(1)),y)
- echo "$(1)" >> $(PKG_INSTALL_STAMP)
+ compile: $(PKG_INSTALL_STAMP).$(1)
endif
+ $(PKG_INSTALL_STAMP).$(1): prepare-package-install
+ echo "$(1)" >> $(PKG_INSTALL_STAMP)
endif
endif