aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-dumpinfo.mk
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2017-10-31 21:29:50 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-11-25 20:02:04 +0100
commit2cb75cd8b9d451bde0cfffce80fa67d58944c44b (patch)
treed6d164cbdad1411c62a318dd8af08e17188386f5 /include/package-dumpinfo.mk
parent40868e3bb6d81510425673d693a8d3abcc4193f7 (diff)
downloadupstream-2cb75cd8b9d451bde0cfffce80fa67d58944c44b.tar.gz
upstream-2cb75cd8b9d451bde0cfffce80fa67d58944c44b.tar.bz2
upstream-2cb75cd8b9d451bde0cfffce80fa67d58944c44b.zip
build: allow defining license information per binary package
At the moment, license information can only be specified on a "per source package" level while other metadata fields (e.g. maintainer) can be given for each binary package. Apply the same logic for license fields as well. This can be used e.g. in cases where a library is distributed under some license while related tools are distributed under a different one. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'include/package-dumpinfo.mk')
-rw-r--r--include/package-dumpinfo.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/package-dumpinfo.mk b/include/package-dumpinfo.mk
index b717c1b472..1be7d958d4 100644
--- a/include/package-dumpinfo.mk
+++ b/include/package-dumpinfo.mk
@@ -46,8 +46,8 @@ $(if $(filter nonshared,$(PKGFLAGS)),,Repository: $(if $(FEED),$(FEED),base)
Maintainer: $(MAINTAINER)
$(if $(USERID),Require-User: $(USERID)
)Source: $(PKG_SOURCE)
-$(if $(PKG_LICENSE),License: $(PKG_LICENSE)
-)$(if $(PKG_LICENSE_FILES),LicenseFiles: $(PKG_LICENSE_FILES)
+$(if $(LICENSE),License: $(LICENSE)
+)$(if $(LICENSE_FILES),LicenseFiles: $(LICENSE_FILES)
)Type: $(if $(Package/$(1)/targets),$(Package/$(1)/targets),$(if $(PKG_TARGETS),$(PKG_TARGETS),ipkg))
$(if $(KCONFIG),Kernel-Config: $(KCONFIG)
)$(if $(BUILDONLY),Build-Only: $(BUILDONLY)