aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-defaults.mk
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2016-10-05 17:28:46 +0300
committerJohn Crispin <john@phrozen.org>2016-10-15 11:36:51 +0200
commit7c8c3226dc8ecd2b77d1d1e8215e0fbb52819cd7 (patch)
tree0dff2ddbe2262ac8bdc9e32250b02b320cbab219 /include/package-defaults.mk
parent02d5f9477be31d2ca27d4e9f4d2d19f964c40c7c (diff)
downloadupstream-7c8c3226dc8ecd2b77d1d1e8215e0fbb52819cd7.tar.gz
upstream-7c8c3226dc8ecd2b77d1d1e8215e0fbb52819cd7.tar.bz2
upstream-7c8c3226dc8ecd2b77d1d1e8215e0fbb52819cd7.zip
build: copy contents of 'src' folder to build dirs (if present)
The normal Prepare step for a build is unpack, apply patches. But for certain packages, patches contain whole files, which would be nice to have separately and copied over as a last step in the Prepare phase. We need it for some other packages + patches, but I think the 'hostapd' package can be used as a test for this. As a quick note: the reason the condition is being evaluated as `[ ! -d ./src/ ] || $(CP) ./src/* $(HOST_BUILD_DIR)` and not with `[ -d ./src/ ] && $(CP) ./src/* $(HOST_BUILD_DIR)` is that the latter would translate in a build failure if the `src` folder is not present (the exit code would be 1). The first one, succeeds for both cases (if `src` present or not). Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'include/package-defaults.mk')
-rw-r--r--include/package-defaults.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/package-defaults.mk b/include/package-defaults.mk
index 4eb5409909..487811c0e2 100644
--- a/include/package-defaults.mk
+++ b/include/package-defaults.mk
@@ -62,6 +62,7 @@ Build/Patch:=$(Build/Patch/Default)
ifneq ($(strip $(PKG_UNPACK)),)
define Build/Prepare/Default
$(PKG_UNPACK)
+ [ ! -d ./src/ ] || $(CP) ./src/* $(PKG_BUILD_DIR)
$(Build/Patch)
endef
endif