aboutsummaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-12-14 00:36:28 +0100
committerJo-Philipp Wich <jo@mein.io>2016-12-14 01:05:06 +0100
commite2f8d200f598c67534c6292d732f7927b3609473 (patch)
tree7763ff461b66d996ddd4685d99f162f3103eea7a /include/netfilter.mk
parent2daab45cae3cfc09bae96f4326a3963a7504e86d (diff)
downloadupstream-e2f8d200f598c67534c6292d732f7927b3609473.tar.gz
upstream-e2f8d200f598c67534c6292d732f7927b3609473.tar.bz2
upstream-e2f8d200f598c67534c6292d732f7927b3609473.zip
netfilter: drop proprietary xt_id match
The xt_id match was used by the firewall3 package to track its own rules but the approach has been changed to use xt_comment instead now, so we can drop this nonstandard extension. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index c793ce5ac1..a4e495e644 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -39,13 +39,12 @@ $(eval $(if $(NF_KMOD),$(call nf_add,IPT_CORE,CONFIG_IP_NF_FILTER, $(P_V4)iptabl
$(eval $(if $(NF_KMOD),$(call nf_add,IPT_CORE,CONFIG_IP_NF_MANGLE, $(P_V4)iptable_mangle),))
# userland only
-$(eval $(if $(NF_KMOD),,$(call nf_add,IPT_CORE,CONFIG_IP_NF_IPTABLES, xt_standard ipt_icmp xt_tcp xt_udp xt_comment xt_id xt_set xt_SET)))
+$(eval $(if $(NF_KMOD),,$(call nf_add,IPT_CORE,CONFIG_IP_NF_IPTABLES, xt_standard ipt_icmp xt_tcp xt_udp xt_comment xt_set xt_SET)))
$(eval $(call nf_add,IPT_CORE,CONFIG_NETFILTER_XT_MATCH_LIMIT, $(P_XT)xt_limit))
$(eval $(call nf_add,IPT_CORE,CONFIG_NETFILTER_XT_MATCH_MAC, $(P_XT)xt_mac))
$(eval $(call nf_add,IPT_CORE,CONFIG_NETFILTER_XT_MATCH_MULTIPORT, $(P_XT)xt_multiport))
$(eval $(call nf_add,IPT_CORE,CONFIG_NETFILTER_XT_MATCH_COMMENT, $(P_XT)xt_comment))
-$(eval $(call nf_add,IPT_CORE,CONFIG_NETFILTER_XT_MATCH_ID, $(P_XT)xt_id))
#cluster
$(eval $(call nf_add,IPT_CLUSTER,CONFIG_NETFILTER_XT_MATCH_CLUSTER, $(P_XT)xt_cluster))