aboutsummaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2020-10-09 16:32:48 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2020-10-24 22:28:37 +0800
commitc6bdd7321f8c4fb453e03b48595bcfc87b10331a (patch)
tree8cb7a5ccc326215ca077757048e7ec1a5c491fb7 /include/netfilter.mk
parentd1592306cc07b9003d554653fc7c53c9168effa7 (diff)
downloadupstream-c6bdd7321f8c4fb453e03b48595bcfc87b10331a.tar.gz
upstream-c6bdd7321f8c4fb453e03b48595bcfc87b10331a.tar.bz2
upstream-c6bdd7321f8c4fb453e03b48595bcfc87b10331a.zip
netfilter.mk: use CONFIG_NETFILTER_XT_TARGET_REDIRECT
CONFIG_IP_NF_TARGET_REDIRECT is a compat option since upstream commit 2cbc78a2 ("netfilter: combine ipt_REDIRECT and ip6t_REDIRECT"). That happened since linux 3.10 Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 2047dcc842..9f22512d68 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -200,7 +200,7 @@ $(eval $(if $(NF_KMOD),,$(call nf_add,IPT_NAT6,CONFIG_IP6_NF_TARGET_NPT, ip6t_DN
$(eval $(call nf_add,IPT_NAT,CONFIG_IP_NF_TARGET_MASQUERADE, $(P_V4)ipt_MASQUERADE, lt 5.2))
$(eval $(call nf_add,IPT_NAT,CONFIG_NETFILTER_XT_TARGET_MASQUERADE, $(P_XT)xt_MASQUERADE, ge 5.2))
-$(eval $(call nf_add,IPT_NAT,CONFIG_IP_NF_TARGET_REDIRECT, $(P_XT)xt_REDIRECT))
+$(eval $(call nf_add,IPT_NAT,CONFIG_NETFILTER_XT_TARGET_REDIRECT, $(P_XT)xt_REDIRECT))
# nat-extra