aboutsummaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorAlin Nastac <alin.nastac@gmail.com>2018-06-25 10:22:21 +0200
committerJohn Crispin <john@phrozen.org>2018-06-26 08:57:25 +0200
commitab07ae2f27dd920cb7ba186d9f7ad2ccb1c980c4 (patch)
treefe977e7a9d888a12f6528227c408051db5fb18a8 /include/netfilter.mk
parent094d49cddf9392361b2d9cc1fe4ea08cb45d0d8c (diff)
downloadupstream-ab07ae2f27dd920cb7ba186d9f7ad2ccb1c980c4.tar.gz
upstream-ab07ae2f27dd920cb7ba186d9f7ad2ccb1c980c4.tar.bz2
upstream-ab07ae2f27dd920cb7ba186d9f7ad2ccb1c980c4.zip
netfilter: add bpf match support
Add xt_bpf modules to {kmod-ipt,iptables-mod}-filter. Match using Linux Socket Filter. Expects a BPF program in decimal format. This is the format generated by the nfbpf_compile utility. Signed-off-by: Alin Nastac <alin.nastac@gmail.com>
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 5d532cea5b..510aa183ca 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -106,6 +106,7 @@ $(eval $(call nf_add,IPT_PHYSDEV,CONFIG_NETFILTER_XT_MATCH_PHYSDEV, $(P_XT)xt_ph
# filter
$(eval $(call nf_add,IPT_FILTER,CONFIG_NETFILTER_XT_MATCH_STRING, $(P_XT)xt_string))
+$(eval $(call nf_add,IPT_FILTER,CONFIG_NETFILTER_XT_MATCH_BPF, $(P_XT)xt_bpf))
# ipopt