aboutsummaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-11-18 18:15:56 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-12-15 14:28:50 +0100
commit89806545cc1711f4e33c1c2ac5265aec4afe8078 (patch)
tree47f3c173eba57fda29940eacb8be76d4d7855f7c /include/netfilter.mk
parent35929059b757de92ff14f6f91addf034302b5635 (diff)
downloadupstream-89806545cc1711f4e33c1c2ac5265aec4afe8078.tar.gz
upstream-89806545cc1711f4e33c1c2ac5265aec4afe8078.tar.bz2
upstream-89806545cc1711f4e33c1c2ac5265aec4afe8078.zip
kernel: netfilter: Add nf_tproxy_ipv{4,6} and nf_socket_ipv{4,6}
The nf_socket.ko module was split in commit 8db4c5be88f ("netfilter: move socket lookup infrastructure to nf_socket_ipv{4,6}.c") into a common, n IPv4 and an IPv6 part. The nf_tproxy.ko module was split in commit 45ca4e0cf27 ("netfilter: Libify xt_TPROXY") into a common, an IPv4 and an IPv6 part. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 5bf3dbdb02..b73cc794b6 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -259,7 +259,11 @@ $(eval $(call nf_add,IPT_DEBUG,CONFIG_NETFILTER_XT_TARGET_TRACE, $(P_XT)xt_TRACE
# tproxy
$(eval $(call nf_add,IPT_TPROXY,CONFIG_NETFILTER_XT_MATCH_SOCKET, $(P_XT)xt_socket))
+$(eval $(call nf_add,IPT_TPROXY,CONFIG_NF_SOCKET_IPV4, $(P_V4)nf_socket_ipv4, ge 4.10))
+$(eval $(call nf_add,IPT_TPROXY,CONFIG_NF_SOCKET_IPV6, $(P_V6)nf_socket_ipv6, ge 4.10))
$(eval $(call nf_add,IPT_TPROXY,CONFIG_NETFILTER_XT_TARGET_TPROXY, $(P_XT)xt_TPROXY))
+$(eval $(call nf_add,IPT_TPROXY,CONFIG_NF_TPROXY_IPV4, $(P_V4)nf_tproxy_ipv4, ge 4.18))
+$(eval $(call nf_add,IPT_TPROXY,CONFIG_NF_TPROXY_IPV6, $(P_V6)nf_tproxy_ipv6, ge 4.18))
# led
$(eval $(call nf_add,IPT_LED,CONFIG_NETFILTER_XT_TARGET_LED, $(P_XT)xt_LED))