aboutsummaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2020-04-21 02:29:51 -0600
committerDaniel Golle <daniel@makrotopia.org>2020-10-30 00:39:09 +0000
commit7f94e2afcf090f751c9f7f7ea46e8ef8d93ee84b (patch)
tree6d03bb66da66065e3458d2986fd913c0065d0807 /include/netfilter.mk
parentc3a4cddaaf453b9387e0ce3c16c06376d8adde28 (diff)
downloadupstream-7f94e2afcf090f751c9f7f7ea46e8ef8d93ee84b.tar.gz
upstream-7f94e2afcf090f751c9f7f7ea46e8ef8d93ee84b.tar.bz2
upstream-7f94e2afcf090f751c9f7f7ea46e8ef8d93ee84b.zip
kmod-nft-reject: Fix for "nft_reject_ipv4.ko missing" warning
Seeing the following: ERROR: module '/home/philipp/lede/build_dir/target-x86_64_musl/linux-x86_64/linux-5.4.33/net/ipv4/netfilter/nft_reject_ipv4.ko' is missing. modules/netfilter.mk:1068: recipe for target '/home/philipp/lede/bin/targets/x86/64/packages/kmod-nft-core_5.4.33-1_x86_64.ipk' failed make[3]: *** [/home/philipp/lede/bin/targets/x86/64/packages/kmod-nft-core_5.4.33-1_x86_64.ipk] Error 1 Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 2c71c07056..b00cdd81c6 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -344,7 +344,7 @@ $(eval $(if $(NF_KMOD),$(call nf_add,NFT_CORE,CONFIG_NFT_NUMGEN, $(P_XT)nft_numg
$(eval $(if $(NF_KMOD),$(call nf_add,NFT_CORE,CONFIG_NFT_OBJREF, $(P_XT)nft_objref),))
$(eval $(if $(NF_KMOD),$(call nf_add,NFT_CORE,CONFIG_NFT_QUOTA, $(P_XT)nft_quota),))
$(eval $(if $(NF_KMOD),$(call nf_add,NFT_CORE,CONFIG_NFT_REDIR, $(P_XT)nft_redir),))
-$(eval $(if $(NF_KMOD),$(call nf_add,NFT_CORE,CONFIG_NFT_REJECT, $(P_XT)nft_reject $(P_V4)nft_reject_ipv4 $(P_V6)nft_reject_ipv6),))
+$(eval $(if $(NF_KMOD),$(call nf_add,NFT_CORE,CONFIG_NFT_REJECT CONFIG_NFT_REJECT_IPV4 CONFIG_NFT_REJECT_IPV6, $(P_XT)nft_reject $(P_V4)nft_reject_ipv4 $(P_V6)nft_reject_ipv6),))
$(eval $(if $(NF_KMOD),$(call nf_add,NFT_CORE,CONFIG_NFT_REJECT_INET, $(P_XT)nft_reject_inet),))
$(eval $(if $(NF_KMOD),$(call nf_add,NFT_BRIDGE,CONFIG_NFT_BRIDGE_META, $(P_EBT)nft_meta_bridge),))