aboutsummaryrefslogtreecommitdiffstats
path: root/include/netfilter.mk
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2020-07-27 00:24:23 -0700
committerYousong Zhou <yszhou4tech@gmail.com>2020-10-24 22:28:37 +0800
commit32931f18f274741795789e669b92ab6b73e93963 (patch)
treebe76f9d9cc2bff61a33170d3634b5a3ea72b3726 /include/netfilter.mk
parent4c2141535063b6fe61f36c9bffab7684a48344c5 (diff)
downloadupstream-32931f18f274741795789e669b92ab6b73e93963.tar.gz
upstream-32931f18f274741795789e669b92ab6b73e93963.tar.bz2
upstream-32931f18f274741795789e669b92ab6b73e93963.zip
netfilter.mk: add version conditional for CONFIG_NF_CT_PROTO_GRE
Kernel commit 22fc4c4c9fd6 ("netfilter: conntrack: gre: switch module to be built-in") moved the CT GRE code into the core nf_conntrack.ko module and changed the CONFIG_NF_CT_PROTO_GRE option to boolean for kernel 5.1 and onwards. CONFIG_NF_CT_PROTO_GRE at the moment has no prompt and can only be selected by NF_CONNTRACK_PPTP Fixes: FS#2990 (partial) Ref: https://bugs.openwrt.org/index.php?do=details&task_id=2990 Signed-off-by: Tony Ambardar <itugrok@yahoo.com> [note that the option now can not be enabled on its own] Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'include/netfilter.mk')
-rw-r--r--include/netfilter.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 3c217db106..8776391f96 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -219,7 +219,7 @@ $(eval $(call nf_add,NF_NATHELPER,CONFIG_NF_NAT_FTP, $(P_XT)nf_nat_ftp))
$(eval $(call nf_add,NF_NATHELPER_EXTRA,CONFIG_NF_CONNTRACK_BROADCAST, $(P_XT)nf_conntrack_broadcast))
$(eval $(call nf_add,NF_NATHELPER_EXTRA,CONFIG_NF_CONNTRACK_AMANDA, $(P_XT)nf_conntrack_amanda))
$(eval $(call nf_add,NF_NATHELPER_EXTRA,CONFIG_NF_NAT_AMANDA, $(P_XT)nf_nat_amanda))
-$(eval $(call nf_add,NF_NATHELPER_EXTRA,CONFIG_NF_CT_PROTO_GRE, $(P_XT)nf_conntrack_proto_gre))
+$(eval $(call nf_add,NF_NATHELPER_EXTRA,CONFIG_NF_CT_PROTO_GRE, $(P_XT)nf_conntrack_proto_gre, lt 5.1))
$(eval $(call nf_add,NF_NATHELPER_EXTRA,CONFIG_NF_NAT_PROTO_GRE, $(P_V4)nf_nat_proto_gre))
$(eval $(call nf_add,NF_NATHELPER_EXTRA,CONFIG_NF_CONNTRACK_H323, $(P_XT)nf_conntrack_h323))
$(eval $(call nf_add,NF_NATHELPER_EXTRA,CONFIG_NF_NAT_H323, $(P_V4)nf_nat_h323))