aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-09-29 17:45:54 +0200
committerFelix Fietkau <nbd@nbd.name>2018-09-29 18:09:45 +0200
commitc3a0102195a2902f1964b667fb86031308c78f9d (patch)
treeddd64be97f89155095f034ad93da8d7c28ff2ca3 /include/kernel.mk
parent911cacfc35e0861f2ad3f9e9420fbf5ca7d3160e (diff)
downloadupstream-c3a0102195a2902f1964b667fb86031308c78f9d.tar.gz
upstream-c3a0102195a2902f1964b667fb86031308c78f9d.tar.bz2
upstream-c3a0102195a2902f1964b667fb86031308c78f9d.zip
build: fix kernel headers install for uml
The kernel headers makefile needs to override LINUX_KARCH Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index c169550f48..97bcfe3f0b 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -97,7 +97,7 @@ endif
KERNEL_MAKE = $(MAKE) $(KERNEL_MAKEOPTS)
-KERNEL_MAKE_FLAGS := \
+KERNEL_MAKE_FLAGS = \
HOSTCFLAGS="$(HOST_CFLAGS) -Wall -Wmissing-prototypes -Wstrict-prototypes" \
CROSS_COMPILE="$(KERNEL_CROSS)" \
ARCH="$(LINUX_KARCH)" \