aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2018-12-03 09:16:23 +0100
committerRafał Miłecki <rafal@milecki.pl>2018-12-03 09:34:57 +0100
commit966ba6daa430922e41ca7598385817f5a611c9c7 (patch)
tree786efbdd6acfe24072dd8f0fcd53e0a44870d8c1 /include/kernel.mk
parent73127a878dca3da42c35400e2c63a24a2d664088 (diff)
downloadupstream-966ba6daa430922e41ca7598385817f5a611c9c7.tar.gz
upstream-966ba6daa430922e41ca7598385817f5a611c9c7.tar.bz2
upstream-966ba6daa430922e41ca7598385817f5a611c9c7.zip
kernel: fix downloading rcX releases
They are no longer stored in the "testing" subdirectory and are not available as .tar.xz archives. If -rc is detected download it from the git.kernel.org and use .tar.gz. Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk11
1 files changed, 9 insertions, 2 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 62a8e99e2d..38613756c7 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -59,8 +59,15 @@ else
LINUX_KERNEL:=$(KERNEL_BUILD_DIR)/vmlinux
- LINUX_SOURCE:=linux-$(LINUX_VERSION).tar.xz
- ifeq ($(call qstrip,$(CONFIG_EXTERNAL_KERNEL_TREE))$(call qstrip,$(CONFIG_KERNEL_GIT_CLONE_URI)),)
+ ifneq (,$(findstring -rc,$(LINUX_VERSION)))
+ LINUX_SOURCE:=linux-$(LINUX_VERSION).tar.gz
+ else
+ LINUX_SOURCE:=linux-$(LINUX_VERSION).tar.xz
+ endif
+
+ ifneq (,$(findstring -rc,$(LINUX_VERSION)))
+ LINUX_SITE:=https://git.kernel.org/torvalds/t
+ else ifeq ($(call qstrip,$(CONFIG_EXTERNAL_KERNEL_TREE))$(call qstrip,$(CONFIG_KERNEL_GIT_CLONE_URI)),)
LINUX_SITE:=@KERNEL/linux/kernel/v$(word 1,$(subst ., ,$(KERNEL_BASE))).x
else
LINUX_UNAME_VERSION:=$(strip $(shell cat $(LINUX_DIR)/include/config/kernel.release 2>/dev/null))