aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-14 15:36:39 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-17 10:36:25 +0100
commit7a315b0b5d6aa91695853a8647383876e4b49a7a (patch)
treeca99d91b9ec9408e37d30f2983847fc5a500d4a7 /include/kernel.mk
parent720b99215da295a2e7b4acdef30b58bec6acedc2 (diff)
downloadupstream-7a315b0b5d6aa91695853a8647383876e4b49a7a.tar.gz
upstream-7a315b0b5d6aa91695853a8647383876e4b49a7a.tar.bz2
upstream-7a315b0b5d6aa91695853a8647383876e4b49a7a.zip
build: implement make check and make package/X/check
This is intended to be used for a wide array of package sanity checks. The first check that is implemented is for the hash of downloaded files. It checks: - Missing hash - Use of SHA256 instead of MD5 - dl/<file> hash not matching hash in makefile - deprecated MD5SUM variable The deprecated MD5SUM variable check is skipped for feeds/ until OpenWrt is updated as well Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 2721c83d8e..4e66c0c76f 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -5,8 +5,15 @@
# See /LICENSE for more information.
#
+ifneq ($(filter check,$(MAKECMDGOALS)),)
+CHECK:=1
+DUMP:=1
+endif
+
ifeq ($(__target_inc),)
- include $(INCLUDE_DIR)/target.mk
+ ifndef CHECK
+ include $(INCLUDE_DIR)/target.mk
+ endif
endif
ifeq ($(DUMP),1)